Selenium Web Test Plugin

Aus expecco Wiki (Version 2.x)
Wechseln zu: Navigation, Suche

Einführung

Das Selenium Plugin realisiert eine Schnittstelle zum open-source Selenium Webtest framework. Es unterstützt capture/replay von Webbrowsersitzungen. Es nutzt einen erweiterten Firefox-Browser (und Selenium IDE) zum Aufzeichnen, und kann die gängigen Browser (via Selenium RC) zum Ausführen nutzen. Bei der Aufzeichnung werden Nutzerinteraktionen sowie Validierungsschritte vermerkt und anschließend als Aktivitätsdiagramm importiert. Diese können sofort wieder ausgeführt werden (replay), oder im Editor nachbearbeitet, refaktoriert oder parametrisiert werden.

Die Selenium Library stellt zu allen Selenium-Funktionen entsprechende Aktionsbausteine bereit. Somit wird es möglich, Selenium nicht lediglich als textuelles Script zu nutzen, sondern in Kombination mit allen anderen Aktionen in einem graphischen Diagramm komplexere Szenarien zu modellieren. Aufgenommene Browseraktionen werden wie alle anderen Aktionen im Diagrammeditor bearbeitet. Insbesondere ist es möglich, Eingabewerte aus anderen Quellen bereit zustellen (Datenbanken, Testdatengeneratoren etc.) oder weitere Validierungen gegen Datenbanken oder andere durchzuführen. Außerdem können Teilsequenzen parametrisiert werden, um sie in Schleifen oder komplexeren Szenarien wieder zu verwenden.

Beachten Sie bitte, dass einfaches Abspielen einer vormals aufgenommenen Sequenz in den seltensten Fällen den Anforderungen des Tests genügt. Üblicherweise müssen Parameter- und Eingangswerte variabel sein und oft dynamisch berechnet werden. Außerdem ist die Struktur der Webseiten in vielen Fällen dynamisch abhängig vom Inhalt, und nicht gleich der bei der Aufzeichnung. Zum Beispiel können Listen zusätzliche Zeilen oder Spalten enthalten, oder zusätzliche Schaltflächen zum Blättern erscheinen. Diese müssen oft in einer Weise bedient werden, die vom aktuellen Inhalt abhängt - teilweise sogar in Schleifen (blättern bis ein bestimmter Eintrag erscheint).

Die Kombination von Selenium-Kommandos (und Verfügbarkeit als Expecco-Aktionsblöcke) mit der in expecco eingebauten dynamischen Ausführung (if- und Schleifenkonstrukte) macht dieses zu einem optimalen Werkzeug um komplexe Webapplikationen zu testen. Die umfangreichen Möglichkeiten von expecco werden nun in einem Tool mit denen von Selenium kombiniert.

Zusammenfassung der Eigenschaften

  • Modellbasierte Testentwicklung kombiniert mit Capture & Replay
  • Wiedergabe/Testlauf auf allen gängigen Browsern
  • Aufnahme von Browser-Sitzungen mit Mozilla Firefox
  • Komfortables Zusammenstellen neuer Aktionsblöcke mit Benutzerinteraktionen
  • Leichte Parametrisierung von Webformularen und automatisches Anlegen von CSV Tabellen mit Eingabewerten
  • Kombination von UI-Tests mit anderen Systemen, Messgeräten, Sensoren, Datenbanken, Mobilgeräten etc.
  • Neu-Aufnahme (rerecording) von Teilsequenzen, ohne dass die gesamte Sitzung erneut wiederholt werden muss
  • Hohe Wiederverwendbarkeit von Teilsequenzen durch Herausfaktorieren von gemeinsamen Aktionen (z.B. login-Sequenzen, Formulareingaben, Tabellenprüfungen etc.)
  • Messung von Antwortzeiten
  • Lastgenerierung und Leistungsmessungen

Selenium IDE

Selenium IDE ist eine in JavaScript geschrieben Erweiterung für den Mozilla Firefox Browser. Damit werden Interaktionen mit dem Browser aufgezeichnet und in expecco als Aktivitätsdiagramm importiert. Die Wiedergabe erfolgt auf den gängigen Browsern (Internet Explorer, Firefox, Safari, Opera etc.). Selenium IDE ist ein Open Source Tool [1]. Dokumentation und weitere Informationen finden Sie auf der Webseite [2].

Erste Schritte

Aufzeichnung starten

Selenium IDE: Aufnahmemodus
  • Menü: "Extras" ► "Plugins" ► "Webtest" ► "Aufzeichnung starten..." ( oder klicken Sie auf die Schaltfläche Icon Start Selenium Capture.png ).
  • Automatisch startet Firefox mit Selenium IDE
    • Die Selenium IDE kann auch manuell gestartet werden. Klicken Sie im Firefox auf "Ansicht" ► "Sidebar" ► "Selenium IDE" oder um die Selenium IDE als eigenständiges Fenster zu öffnen auf "Extras" ► "Selenium IDE"
  • Nach dem Start ist bereits automatisch der Record Mode aktiviert (roter Record-Button)
  • Alle Interaktionen mit der Webseite werden nun aufgezeichnet
  • Mit der rechten Maustaste haben Sie über ein Kontextmenü Zugriff auf spezielle Kommandos für ein entsprechendes Element
  • Im Selenium IDE Fenster erfolgt die Protokollierung der Aktionen
    • Änderungen können Sie auch schon hier vornehmen
    • Einfügen manueller Aktionen möglich
  • Ist das gewünschte Szenario durchgeführt, beenden Sie die Aufzeichnung durch Drücken des roten Record-Buttons
  • Über den folgenden Button übertragen Sie die Aufzeichnung nach expecco expecco button
    • Alternativ kann eine Aufzeichnung auch manuell übertragen werden
  • Geben Sie im Dialogfenster einen Namen für die Aufzeichnung ein
  • Die Aufzeichnung ist nun in expecco als neuer Baustein mit dem entsprechenden Namen unten im Navigationsbaum zu finden
  • Durch ein Klick auf den Baustein wird dieser im Arbeitsbereich geöffnet
  • Im Reiter "Netzwerk" sind nun die einzelnen Schritte der Aufzeichnung zu sehen
  • Im Reiter "Test" können Sie über den folgenden Button den Test direkt starten Start or Resume Testrun

Schritte refaktorieren

expecco web: Neuen zusammengesetzten Baustein anlegen
expecco web: Neuen zusammengesetzten Baustein anlegen

Logisch zusammen gehörende Schritte wie beispielsweise der Login, das Ausfüllen von Formularen, etc. können zu einem neuen Baustein zusammengefasst werden. Die Testabläufe werden dadurch übersichtlicher und die zusammengefassten Bausteine können besser wiederverwendet werden.

  • Wählen Sie den Reiter "Netzwerk" aus
  • Markieren Sie die Schritte die zusammengefasst werden sollen über ein Auswahlrechteck mit der Maus
  • Durch Klicken der rechten Maustaste auf einen der ausgewählten Schritte erscheint das Kontextmenü für die Auswahl
    Kontextmenü: "Refaktorieren" ► "Neue zusammengesetzte Aktion generieren & ersetzen..."
  • Geben Sie im folgenden Dialogfenster einen Namen für den neuen zusammengesetzten Baustein ein
  • Im aktuellen Aktivitätsdiagramm ist nun der neue zusammengesetzte Baustein als Schritt zu sehen
  • Im Navigationsbaum ist der neue zusammengesetzte Baustein enthalten
  • Diesen Baustein können Sie nun an unterschiedlichen Stellen verwenden
  • Änderungen an diesem Baustein müssen dann nur einmal vorgenommen werden und sind in allen Aktivitätsdiagrammen, in denen der Baustein als Schritt verwendet wird, gültig

Aufzeichnungen funktional erweitern

Aufzeichnungen lassen sich einfach mit Bausteinen aus der mitgelieferten StandardLibary erweitern.

  • Klappen Sie im Navigationsbereich die Elemente "Imports" ► "StandardLibary" aus
  • Wählen Sie eine der Gruppen aus um Zugriff auf die Bausteine zu erhalten
  • Alternativ wählen Sie im Navigationsbereich den Reiter "Search" aus und geben Sie einen Suchbegriff ein
  • Selektieren Sie nun das Aktivitätsdiagramm (z.B. eines zusammengesetzten Bausteins) aus in das Sie den Baustein einfügen wollen
  • Ziehen Sie den gewünschten Baustein per Drag&Drop aus dem Navigationsbereich in das Aktivitätsdiagramm
  • Dann belegen Sie je nach Baustein die Parameter-Pins und/oder verbinden Sie Trigger-Pins mit anderen Bausteinen
  • Dabei müssen Sie darauf achten, dass die Datentypen übereinstimmen oder Sie gegebenenfalls umwandeln

Fehler-Log Bausteine einbauen

  • Zeichnen Sie ein beliebiges Szenario auf
  • Rechtsklicken Sie an einer Stelle auf ein Textelement einer Website
  • Kontextmenü: verifyTextPresent <Name des angeklickten Elements>
  • Exportieren Sie die Aufzeichnung nach expecco
  • Rechtsklicken Sie auf den Schritt "verifyTextPresent"
  • Kontextmenü: "Operationen" ► "Ersetzen durch..."
  • Suchen Sie im Dialogfenster nach "isTextPresent" und wählen dieses aus
  • Klappen Sie im Navigationsbereich die Elemente "Imports" ► "StandardLibary" ► "Assertions, Exceptions & Logging" aus
  • Ziehen Sie den Baustein "Log[Failure]" in das Aktivitätsdiagramm des Tests
  • Alternativ wählen Sie im Navigationsbereich den Reiter "Search" aus und geben Sie den Name des Bausteins als Suchbegriff ein
  • Rechtsklicken Sie auf den "Log[Failure]"-Schritt
  • Kontextmenü: "Spezielle Pins..." ► "Trigger-Eingang"
  • Verbinden sie den "triggerNo"-Ausgang von "isTextPresent" mit dem gerade erstellten Trigger-Eingang
  • Doppelklicken Sie auf den "errorMessage"-Eingang und geben Sie eine Fehlermeldung ein

Wird der Test nun ausgeführt und das ausgewählte Textelement erscheint nicht, dann wird der Test mit einem Fehler abgebrochen. Analog können auch Warnungen ausgegeben werden, die den Test nicht abbrechen.

Spezielle Aufgaben

Webformulare ausfüllen über eine CSV-Datei

  • Wählen Sie den Reiter "Netzwerk" aus
  • Markieren Sie die Schritte, die das Ausfüllen des Webformulars umfassen inklusive Navigation zum Formular. Bedenken Sie, dass diese Schritte später für jeden Eintrag in der CSV-Datei ausgeführt werden. Zur Markierung stehen wie gewohnt folgende Möglichkeiten zur Verfügung
    • Maus: Ziehen eines Auswahlrechtecks
    • Tastatur: [Vorsicht: Aktuelle Überarbeitung der Shortcuts!]
  • Durch Klicken der rechten Maustaste auf einen der ausgewählten Schritte erscheint das Kontextmenü für die Auswahl
  • Kontextmenü: "Refaktorieren" ► "Neue zusammengesetzte Web-Parameter-Aktion generieren & ersetzen..."
  • Geben Sie im Dialogfenster einen Namen für den neuen Web-Parameter-Baustein ein
  • Bestätigen Sie den folgenden Dialog mit Ja, wenn Sie für die extrahierten Wertepaare des Webformulars eine CSV-Datei als Vorlage erstellen möchten und speichern diese ab.
  • Klappen Sie im Navigationsbereich die Elemente "Imports" ► "StandardLibary" ► "Files & Directories" ► "Files" aus
  • Alternativ wählen Sie im Navigationsbereich den Reiter "Search" aus und geben Sie den Name des Bausteins als Suchbegriff ein
  • Ziehen Sie den Baustein "File [ReadCSV]" in das Aktivitätsdiagramm des Tests
  • Doppelklicken Sie auf den Eingang "CSVFileOrStringCol" und geben Sie den Pfad und den Namen der zuvor gespeicherten CSV-Datei ein
  • Verbinden Sie den Ausgang "CSVLineValues" mit dem Eingang "optionalParameterSet" am erstellten Schritt

Benutzereingabe miteinbeziehen

  • Wählen Sie den Reiter "Netzwerk" aus
  • Klappen Sie im Navigationsbereich die Elemente "Imports" ► "StandardLibary" ► "GUI-Dialogs" aus
  • Ziehen Sie den Baustein "Dialog [Request String]" in das Aktivitätsdiagramm des Tests
  • Doppelklicken Sie auf den Eingang "requestLabel" und geben Sie eine Eingabeaufforderung an den Benutzer ein
  • Am Eingang "title" geben Sie einen Titel für die Dialogfenster ein
  • Verbinden Sie den Ausgang "answer" mit dem Eingang des Schrittes für den der abgefragte Wert verwendet werden soll
  • Rechtsklicken Sie erneut und entfernen Sie das Häkchen vor "Parameter"

Bekannte Probleme / Hints und Tricks

click vs. clickAndWait
Die Selenium IDE zeichnet abhängig von Umständen während der Aufzeichnung (Übertragungsrate, Antwortzeit des Webservers) das Klicken eines Elements und folgendes Laden einer Seite manchmal als ">click<" und manchmal als ">clickAndWait<" auf. Deshalb sollte ein Test nach der Aufzeichnung durch (mehrmalige) Wiedergabe in der Selenium IDE verifiziert werden.
  • Fehlermöglichkeit 1:
    • Es wird das Kommando ">click<" aufgezeichnet, obwohl eine Seite nachgeladen wird. Da der Ladevorgang unterschiedlich lange dauern kann, bricht Selenium IDE beim Folgekommando ab, da dieses schon ausgeführt wird, obwohl die Seite noch nicht vollständig geladen wurde.
    • Behebung:
    Ersetzen Sie das Kommando ">click<" durch das Kommando ">clickAndWait<" (Kontextmenu: "Baustein Ersetzen...").
  • Fehlermöglichkeit 2:
    • Es wird das Kommando ">clickAndWait<" aufgezeichnet, obwohl keine Seite nachgeladen wird. Dies führt zu einem Abbruch der Ausführung in der Selenium IDE nach der als Timeout spezifizierten Zeit, da auf das Laden einer neuen Seite gewartet wird, obwohl kein Ladevorgang erfolgt.
    • Behebung:
    Ersetzen Sie das Kommando ">clickAndWait<" durch das Kommando ">click<"
Aufzeichnen von Aktionen in Selenium IDE, während Seite noch geladen wird
  • Problem: Aktionen, die ausgeführt werden, solange eine Seite noch nicht ganz geladen ist, wird eventuell von der Selenium IDE nicht aufgezeichnet.
  • Beispiel: Klicken auf einen Link in einem (schon sichtbaren) Navigationsmenü, während die Seite noch geladen wird
  • Lösung: Führen Sie erst Aktionen auf der Seite aus, nachdem diese komplett geladen wurde. (Sichtbar in der Statusbar des Browsers)

Weitere Infos

Aktionsblöcke für Selenium-Kommandos

Zu jedem Selenium-Kommando gibt es in der Bibliothek einen entsprechenden Aktionsblock Selenium Library.

Grundsätzlich sind die Aktionen in Gruppen eingeteilt, die durch einen Präfix gekennzeichnet sind:

  • Is - Kommandos mit einem "Is"-Präfix liefern einen TRUE/FALSE Wahrheitswert. Beispiel: "isTextPresent"
  • Get - Kommandos mit "Get"-Präfix liefern einen STRING mit dem angeforderten Wert. Beispiel: "getTitle"
  • Assertion - Kommandos mit "Assert"-Präfix vergleichen gegen einen erwarteten Sollwert und melden einen Testfehler, falls der Istwert ungleich ist. Falls der Testfehler nicht behandelt wird (Exception-Ausgang bzw. Exception ignorieren), führt dies zum Abbruch des Testfalls mit einem Fehlerstatus. Beispiel: "assertElementHeight" or "assertTextPresent"
  • Verification - Kommandos mit einem "Verify"-Präfix vergleichen gegen einen Sollwert und schreiben einen Log-Eintrag im Falle von Ungleichheit. Der Testfall wird aber fortgeführt. Beispiel: "verifyElementHeight"

Zu jedem Is/Get Kommando gibt es korrespondierende Assert/Verify Kommandos.

Bitte lesen Sie die Offizielle Dokumentation zu Selenium um mehr über die einzelnen Locator und Kommandos zu erfahren. Außerdem finden Sie Informationen zu einzelnen Aktionsblöcken in der "Selenium Library Referenz".

Zusätzliche Funktionen (welche nicht im unterliegenden Selenium vorhanden sind)

Die Bibliothek umfasst auch Zusatzfunktionen, welche nicht im unterliegenden Selenium implementiert wurden. Insbesondere sind dies komplexere Aktionssequenzen zum Sichern von Text oder Werten in Tabellen.

Außerdem wurden Kombiaktionen "waitForElementAndXXX" hinzugefügt, welche die "waitForElementPresent" mit weiteren wie "Click" oder "Type" kombinieren.

Natürlich können und solten Sie eigene Bibliotheken anlegen, welche wiederverwendbare Sequenzen für ihr Testprojekt enthalten.


Zurück zur Online Documentation.



Copyright © 2014-2016 eXept Software AG