Tools TestSuiteDifferenceBrowser/en

Aus expecco Wiki (Version 2.x)
Wechseln zu: Navigation, Suche

This tool determines the differences between two test suites. This may be either the differences between the edited project and another version in a file or the expecco ALM repository, or between two suites in files.

  • To compare the edited project against a file/expecco ALM version,
    select the project item (the root item in the left tree) and choose "Contextmenu" -> "Compare with Version in File..." (that menu item is also found in the "Extras" -> "Tools" menu)

  • To compare individual items of the project against corresponding items in a file,
    select them in the tree, and choose "Contextmenu" -> "More" -> "Compare with Version in File...".

  • To compare two files containing test suites,
    select "Extras" -> "Tools" -> "Compare two Testsuite Files..." in the main menu.

This application is also opened when two individual tree-elements (such as two blocks) are compared using the "Compare with each other" tree menu function.

The upper area is the change-selection area; it consists of 3 lists, showing elements which are only present in the loaded project (left list), changed elements (middle list) and items which are only present in the file. Whenever an item is selected in one of the upper lists, the corresponding element is shown in the lower area. Either as single or in a side-by-side display. The lower left area presents the individual changes (Name, Interface, Datatype, Network etc.), a diff-presentation of the complete XML representation (for experts and developers) and a definition editor.

TestSuiteDiffBrowser1.png

The tool can be used both to get information on what has changed, and to merge multiple projects into a single. This is done by either "adopting" individual changed attributes (select an attribute in the lower left list, and click on the appearing "Adopt Value" button), by "adopting" whole items, or by dragging elements from the upper lists back into your project. Multiple items may be selected to adopt corresponding values or items.

The lower definition editors are full working, except for being readonly. Thus, you can even execute the Test/Demo examples, to check for correct behavior, before adopting.

Notice that this tool is meant for interactive use. For an automatic generation of diff-lists between two versions of a test suite (for example, to automatically generate comment-text for a version management system like CVS, SVN, Mercurial or Git), use the "--diff" command line option.

Back to Online Documentation.



Copyright © 2014-2016 eXept Software AG